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About Avatax 16 extension

Avalara Avatax 16 is well known platform that dynamically delivers instantaneous sales
tax decisions based on precise geo-location. Tax can be calculated for almost all countries in
the world. You don't need to create or rewrite tracking zones, rates, tax rules. AvaTax
continuously updates data, making accurate sales tax calculations available immediately in real
time. Avatax 16 extension performs address validation and normalization, looks for taxability
determination, uses jurisdiction assignment technology for correct and valid tax calculation.

The main purpose of the extension is to calculate tax with Avalara Avatax 16 Platform. A
lot of settings allow to configure extension regarding to specifics of your stores, products,
clients.

All Avatax 16 operations and requests are saved as logs in a table so admin can review
and use existing information for own and business goals.

Avatax 16 extension is easy installed to Magento platform and can be configured
differently for all available stores. If Avatax 16 extension is disabled for any store, tax can be

calculated by using other services (for example, Default Magento Rules).

Flow and integration with StoreFront

Every time when tax need to be calculated (on Shopping Cart, Checkout) and record
sale (Invoice/Credit Memo) for filing and reporting in Avatax system Avatax 16 extension starts
its work.

Calculation is an Avatax request to calculate tax for Order.

Transaction is an Avatax request to record sale (Invoice/Credit Memo) for filing and
reporting in Avatax system.

Validate is an Avatax Request to validate and normalize Shipping Address.

Filter is a log that is created to indicate  situation when
Validate/Calculation/Transaction cannot be performed for entered Shipping Address because
of admin settings for Filter Request (admin is able to select countries and regions which
validation and tax calculation should or should not be performed for). If Shipping Address is

filtered then Validate/Calculation/Transaction is skipped.
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Invoices and Credit memo can be transferred to Avalara admin. Queue is used for this

purpose. So when Queue transaction is performed, log Queue is created.

See Avatax 16 work flow on diagram bellow.

BackOffice

FrontEnd

|
|
|
| Aoy proouet |
‘woan
|
1
|

Be Astounding

astoundcommerce.com

Credit Memo Status in

+ ~ Admin is enanged



Installation

Typical Installation Process

1. If applicable, disable caching (System > Cache Management) and disable compilation
(System > Tools > Compilation)
2. Download the extension via Magento Connect
a. Browse to System > Magento Connect > Magento Connect Manager and Log in
b. Go to the Settings tab and set Preferred State to "Beta," then click Save
Settings
c. Go to the Extensions tab, paste in the Extension Key
(magento-community/OnePica_AvaTax or
http://connect20.magentocommerce.com/community/OnePica_AvaTax
depending on your Magento version), click Install, and confirm that you are
shown a success message.
d. Click Refresh to see the package successfully installed
e. Click Return to Admin in the upper right
3. Flush permissions: Log out of the admin and log back in
4. Enable cache, turn compilation back on, and recompile if you were previously using
those features

Installation Process for Legacy Versions of Magento Professional & Magento Enterprise

1. If applicable, disable caching (System > Cache Management) and disable compilation
(System > Tools > Compilation)
2. Download the latest version. It can be obtained via Magento Connect, Github or
downloaded directly from our website.
3. Extract the contents: Confirm the creation of:
a. /app/etc/modules/OnePica_AvaTax.xml
b. /app/code/community/OnePica/AvaTax/
4. Enable cache, turn compilation back on, and recompile if you were previously using
those features

Connection Settings

To set up Avatax 16 extension go to Admin Panel > System > Configuration > Sales >

Tax > Avatax: Connection Settings
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http://www.magentocommerce.com/magento-connect/sales-tax-extension-for-avalara-s-avatax.html
http://www.magentocommerce.com/magento-connect/sales-tax-extension-for-avalara-s-avatax.html
https://github.com/onepica/avatax
https://github.com/onepica/avatax
http://astoundcommerce.com/magento-extensions/avatax/releases/OnePica_AvaTax-2.6.8.tgz

Connection Settings [STORE VIEW]

Action Enable: calculate tax, submit data v [STORE VIEW]
URL D evélnpment (https:ita x-qa.avir.sh.h.rz} v [STORE WIEW]
Account Number [STORE VIEW]
ey [STORE VIEW]
Company Code [STORE VIEW]

Required. Your company code from the dashboard.

Taxable Country Erazil “ [STORE VIEW]

Eritish Indian Ccean Territary

British Virgin Islands

Erunei

Bulgaria

BEurkina Faso

Burundi

Cambodia

Cameroon

Canada -

Address validation option works only for United States
and Canada

Filter Reguests by Region Mone v [STORE VIEW]
Re-zave settings if Taxable Country was changed to
use this option.

To connect Avatax 16 extension you should enter valid credentials:

> URL: URL of Avalara Service that will provide tax calculation and address validation /
normalization options.

> Account Number: this string is a UUID issued by Avalara to identify the Avalara
account that owns the company identified by the Company Code.

> Key: the Authorization is used to identify the actor (person or system) making the
request.

> Company Code: identifies the company profile/legal entity with which the Avatax 16

operations are associated
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To enable or disable AvaTax please use Action setting under Connection Setting
block:
> Disable: tax will be calculated by default Magento; AvaTax is disabled. Default Magento
settings for tax calculation are present.
> Enable: calculate tax: only tax for Orders is calculated by Avatax. Default Magento
settings for tax calculation are not present. Invoices and Credit Memo cannot be sent to
Avalara admin, Transaction Requests are not created.
> Enable: calculate tax, submit data: tax is calculated for Orders; Invoices and Credit

Memos can be sent to Avalara Admin console. See more details here.

Each time when admin makes some changes in Avatax 16 settings (not only Connection
Settings but settings related to any Avatax 16 option) Ping log is saved to Avatax 16 Log table
(Admin Panel > Sales > Tax > Avatax Logs):

> if all connection settings are valid Avatax 16 extension saves Ping Log with Level
“Success”;

> if at least one Connection Parameter is invalid Avatax 16 extension saves Ping Log with
Level “Error”.
See Logging to find more information about Logs.

User is able to configure Filter Requests by Region option, go here to see how to do it.
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Validation & Normalization

For tax calculation process, Address Validation should be performed.
Address Validation is the process that is used to check the validity and deliverability of

a physical mailing address. The main purpose of Validation is to verify whether address is valid

and really exists.

Address Normalization is process of changing address entered by user to full and

well-formed.

To configure Validation and Normalization of address go to Admin Panel > System >

Configuration > Sales > Tax > Avatax > Shipping Address Options

Shipping Address Options

Address Validation

Address Narmalization

Address Validation Error

Multi-Address Checkout Address
Mormalized Notice

Cnepage Checkout Address
Mormalized Notice

Multi-Address Address Validation
Error

[ Disabled v

Require a validated address from AvaTax to checkout

Disable v

Replac e address with wel-formed one from AvaTax

Unable to validate address.

Only applies if address validation is enabled
Your shipping addresses have been modified

during our validation process. Please canfirm they
are still correct.

Only applies f address normalization is enabled

Your shipping address has been madified during
our validation process. Flease confirm the address

|t the right is accurate.

Only applies if address normalization is enabled

The address "%s’ appears invalid. Flease correct it
or select another address.

P
Only applies if address validation is enabled and shows
OMLY for the mult-address checkout

Admin is able to configure the following Shipping Address Options:
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> Address Validation: This optional step stands for recognition of address before tax
calculation. Admin is able to select one of the following values:

o Disabled: a basic level of validation is performed to verify that AvaTax can
calculate tax on the given address

o Enabled + Allow Order: if non-taxable address is entered tax is not calculated
but user is able to continue and place order.

o Enabled + Prevent Order: the user should enter a valid shipping address on
Shopping Cart or Checkout to continue. If non-taxable address is entered, error
message is displayed and user is not able to proceed.

See Error Handling article to set up the most flexible behavior.

> Address Normalization: this optional step is used to replace address entered by user
with a well-formed address provided by AvaTax during checkout. Two values are
available:

o Disabled: normalized address is sent in Response block of Validation but this
address is not used on Checkout

o Enabled: normalized address is used on Checkout instead of address entered by
user

> Address Validation Error: message will be shown during checkout if address cannot be
validated by Avalara and only if valid error message is not sent in Validate Response. If
Validate Response has error message then it will be shown for user instead of error

message from Address Validation Error field.

NEW YORK, New York, 10038
United States
Edit T: 123457

m

quertyu
Flat Rate I Address Validation Error I quertyu, Connecticut, ooo

) United States
Fixed $5.00 T: 12345

} Unable to validate address.

DO YOU HAVE ANY GIFT ITEMS IN YOUR ORDER?
Add gift options l,\\,

H PAYMENT INFORMATION

Bl oRrDER REVIEW
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> Onepage Checkout Address Normalized Notice: this message is displayed if address
has been modified during validation process and is replaced with address entered by

user on Onepage Checkout (Address Normalization should be enabled)

CHECKOUT METHOL Edit Test User
110 William St
Edit NEW YORE, New York, 10038
United States
EEEMETION Ediit T: 123457

i e b SHIPPING ADDRESS | CHANGE
SHIPPING METHOD i
Test User
110 William Street

- - New York, New York, 10038-
Flat Rate | Onepage Checkout Address Normalized Notice | e L
United States
Fixed $5.00 T: 123457

Your shipping address has been modified during our validation process. Please confirm the
address to the right is accurate.

DO YOU HAVE ANY GIFT ITEMS IN YOUR ORDER?

Add gift options

CONTINUE « Back

B PAYMENT INFORMATION

ﬂ ORDER REVIEW

> Multi-Address Checkout Address Normalized Notice: applies only if address
normalization is enabled. Message is shown if address that has been entered by user on

Multiple Checkout is modified and this modified address is used on Checkout

SELECT ADDRESSES SHIPPING INFORMATION BILLING INFORMATION PLACE ORDER ORDER SUCCESS

SELECT SHIPPING METHOD | Mutti-Address Checkout Address Normalized Notice |

} Your shipping addresses have been modified during our validation process. Please confirm they are still correct.

ADDRESS 1 OF 2

SHIPPING TO | CHANGE ITEMS | EDIT ITEMS

Test User PRODUCT NAME aTy

140 Las Vegas Boulevard North
Las Vegas, Nevada, 89101-2920
United States
T: 12341234

BLUE HORIZONS BRACELETS 1

DO YOU HAVE ANY GIFT ITEMS IN YOUR ORDER?
Add gift options

SHIPPING METHOD

Flat Rate
Fixed $5.00
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> Multi-Address Address Validation Error: applies only if address validation is enabled.
Message is shown on Multiple Checkout if address is invalid. You can use ‘%S’ in your

error message text; in this case ‘%s’ will be replaced with shipping address.

SELECT SHIPPING BILLING PLACE ORDER
ADDRESSES INCADKAATION] INICADRAATION] ORDER SUCCESS

shipping address is used instead of '%s’ in error
message from "Multi-Address Address Validation Error”
block

The address|'Test User, 100 Willim Street, Unknown City, New York 111, United States'lappears invalid.
Please correct it or select another address.

SHIP TO MULTIPLE ADDRESSES

Please select shipping address for applicable items

PRODUCT Qry SEND TO
JACKIE O ROUND 1 Test User, 100 Willim Street, Unknown City, New York 111, United States -
SUNGLASSES

UPDATE QTY & ADDRESSES

Pay attention that address can be normalized only when Response block of Validate
Request contains resolutionQuality: Rooftop. If you get any other resolutionQuality, it
means that address cannot be normalized.

To find more details about Address Validation process go here.

Please note: if user proceeds to Checkout with products that don’t needed shipping
(virtual or downloadable products, Virtual Gift Card Products), then Validation and Normalization

is performed for Billing Address.
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http://developer.avalara.com/api-documentation/avatax-16-api/develop/additional-scenarios#address-validation

Tax Calculations

Avatax 16 extension uses two Request Types for tax calculation:

> Calculation: process of tax calculation for Order. Calculation Request is sent when user
estimates tax in Shopping Cart or places Order.

> Transaction: such request is related to record sale (Invoice/Credit Memo) for filing and

reporting in Avatax system (see details in Queue section). When Invoices / Credit Memo

is sent from Avatax Order Sync Queue table to Avalara admin, tax need to be calculated.
Request Transaction is sent for this purpose.
Calculations and Transactions Requests are similar and have the same structure.
Such Requests include:
- information about user: tax class, buyer type, metadata etc.
- information about transaction: date, transaction type, currency etc.
- information about products: quantity, UPC (or SKU), price, description etc.
- information about shipping: send as new item; shipping costs is sent
Response block of Calculations and Transactions include detail tax amount for every

item and entire Order. Response also contains jurisdiction details, tax types, comments etc

Calculation Details

Calculation Request is sent each time when data needed for tax calculation is changed.
But if request for changed data was sent previously, then new Calculation request is not sent,
but data from previous response is used. It allows to decrease number of Requests.
Example: Shopping Cart
1. User adds product to Cart
2. Enters Country, State and Zip Code
3. Clicks “Estimate”
Result: Calculation Request is sent
4. Selects Shipping Method with price that is higher than 0
5. Clicks “Update Total”
Result: New Calculation Request is sent

6. Select Shipping Method with price that equals 0
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Result. New Calculation Request is not sent because the same request was sent after
step #3
So few Calculation Requests can be sent during tax estimation in Shopping Cart or

Checkout - this is expected behavior.. But Calculation Requests should not be duplicated.

Transaction Details

Transaction Request is sent once when Invoice / Credit Memo is sent to Avalara Admin.
Depending on Transaction Response, Invoice / Credit Memo changes status (read more about

Queue in Avatax 16 Order Sync Queue_article).

Only one Transaction Request is sent for one Invoice / Credit Memo per one processing

Queue.

Business Identification Number

Business Identification Number (Business Identification No) is also known as VAT
Registration ID.

Business Identification No can be sent in Calculation and Transaction Requests if it
is specified by user during order placing. Business Identification No is usually provided by
customer along with Shipping Address. But if user doesn’t specify it in Shipping Address and
specifies it in Billing, then Business Identification No is taken from Billing Address. Business
Identification No is sent in Calculation and Transaction Requests as defaultTaxPayerCode.

To enable / disable displaying of Business ldentification No on StoreFront go to Admin
Panel > System > Configuration > Customers > Customer Configuration > Create New Account

Options and set value for the field “Show VAT Number on Frontend”.

Tax inclusive and exclusive prices

Magento AvaTax extension is able to handle both tax inclusive and exclusive product
prices. Behavior is driven by Magento setting under Admin Panel > System > Configuration >

Tax > Calculation Settings > Catalog prices.
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ax

AvaTax

Tax Classes
Calculation Settings

Catalog Prices Excluding Tax v [WEBSITE]
Excluding Tax
including Tax

Default Tax Destination Calculation
Shopping Cart Display Settings

Orders, Invoices, Credit Memos Display Settings
Fixed Product Taxes

|||||

Default value of Excluding Tax stands for tax calculations based on product prices in
Magento admin panel set without any tax, also called net prices. Below is an example of Order

review page, as customers see it with Excluding Tax setting.

ORDER REVIEW

PRODUCT PRICE QTY SUBTOTAL

SHEA ENFUSED HYDRATING BODY LOTION $28.00 1 $28.00

/ Subtotal $28.00

Shipping & Handling (Flat Rate - Fixed) $5.00

product price from
Magento admin

shipping price from Tax $2.93
[Magento admin

Grand Total $35.03 =22.00 + 5.00 +
(Subtotal) (Shipping)

Forgot an Item? Edit Your Cart

To calculate tax basing on gross price, meaning sale amount and tax being
back-calculated from product price, Catalog prices should be set as Including Tax. Below is

example of Order Review page in this case.
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ORDER REVIEW

PRODUCT PRICE QTY SUBTOTAL

SHEA ENFUSED HYDRATING BODY LOTIOM $28.00 3 $28.00

/

Shipping & Handling (Flat Rate - Fixed) $5.00

product price from
Magente admin

Subtotal $28.00

shipping proce from Tax $2.69
Magento admin ‘
Grand Total $33.00 =28.00 + 5.00
(Subtotal (Shipping
including tax including tax)

Catalog prices option may be set on Website level.

Magento Price Display Settings are hidden and are driven with Calculation Settings,
meaning that prices on StoreFront catalog (categories, product details pages, etc.) are

displayed as they are configured in admin panel, since tax for them is not calculated yet.

In order to provide better user experience, different Display Settings are supported for
Shopping Cart and Order, Invoices, Credit Memos views: They can be set as Including tax,

Excluding tax or Including and Excluding tax.

Display Prices | Including Tax v [STORE VIEW]
Excluding Tax
Display Subtotal [STORE VIEW]
: =g Including and Excluding Tax
Display Shipping Amount TITCTOOTTg TEn ¥ [STORE VIEW]
Display Gift Wrapping Prices ilncluding Tax L [STORE VIEW]
Display Printed Card Prices ! Including Tax v [STORE VIEW]
Include Tax In Grand Total ms v [STORE VIEW]
Display Full Tax Summary i‘fes L [STORE VIEW]
Display Zero Tax Subtotal i_Fau v [STCRE VIEW]
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Orders, Invoices, Credit Memos Display Settings

Display Prices [ Including Tax [STORE VIEW]
Excluding Tax
Display Subtotal [STORE WVIEW]
: — Including and Excluding Tax
Display Shipping Amount IO e [STORE VIEW]
Display Gift Wrapping Prices !Including Tax [STORE VIEW]
Dizplay Printed Card Prices i_'l_r'l_t;lid'ing Tax [STORE VIEW]
Include Tax In Grand Total i‘r’es [STORE WIEW]
Display Full Tax Summary [ Yes [STORE VIEW]
Display Zero Tax Subtotal [h_u [STORE WIEW]

While Catalog Prices are set as Including Tax, Apply Customer Tax: Before / After
Discount configuration is available. It controls, whether Calculation requests are sent before or

after discounts are applied on prices.

Data Mapping

This is section for configuration additional parameters that are sent in Calculation and
Transaction Requests. It impacts tax calculation process.
To configure Data Mapping go to Admin Panel > System > Configuration > Sales > Tax

> Avatax > Data Mapping.
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Data Mapping

Customer Code Format

Shipping Sku

Gift Wrap Crder Sku

Gift Wrap ltems Sku

Gift Wrap Printed Card Sku

Adjustment Refund Sku

Adjustment Fee Sku

Sales Person Code

Location Code

Reference Code 1

Reference Code 2

UPC check

customer_id L
Recommended:. customer_id

'Shipping

Reqguired. The sku sent to dencte shipping ¢ osts.

\GwOrder

Required. The sku sent to dencte gift wrap crder costs.

\Gwitems
Reqguired. The sku sent to dencte gift wrap items costs.

\GwPrintedCard
Required. The gku sent to denote gift wrap printed card
costs.

Qﬁkdjusiment

Required. The sku sent to dencte positive ajustments.
;ﬁdjusiment

Required. The sku sent to dencte negative ajustments.
.F;ﬂ'aijentu.

Optional. The sales person code for orders.

Opticnal. The location ¢ ode for orders.

Optional. An attribute code to pass with each product.
See product attributes in catalog > attributes.

| Disable v

Admin is able to configure following parameters:

> Customer Code Format: it is sent in customerCode line of Request Header. The

following values are available for selecting
o customer_id;
o customer_email;

o customer_name (customer_id).

> Shipping Sku: entered value is sent in Request to identify Shipping Costs item

Entire Order)
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Gift Wrap Items Sku: SKU that is sent to denote gift wrap items costs (Gift Wrapping for
Individual Items)

Gift Wrap Printed Card Sku: SKU that is sent to denote gift wrap Printed Card costs
Adjustment Refund Sku: SKU that is sent to denote positive adjustments

Adjustment Fee Sku: SKU that is sent to denote negative adjustments

Sales Person Code: the salesperson code for orders that is sent in Request Header

Location Code: the location code for orders; optional field

Y YV VYV VY

Reference Code 1, Reference Code 2: optional. An attribute code to pass with each
product (see product attributes in Catalog > Attributes). Admin should enter valid product
attribute to field that is sent in Request for products.

> UPC check: detail information about this option you can find here.

Pay attention that all parameters except UPC check, Reference Code 1 and Reference
Code 2 let users fill in a static values. UPC check, Reference Code 1 and Reference Code 2
can be mapped to dynamic fields.

For example, if admin enters Location Code: 0000 it means that static value “0000” of
LocationCode will be sent for all Calculation and Transaction requests. But if admin enters
Reference Code 1: color it means that specific color of ordered item will be sent in Calculation
and Transaction requests. So Reference Code 1 has dynamic value that changes according to

item attribute value.

Taxability based on UPC

To manage taxability based on UPC admin is able to configure the following settings in
AvaTax Configuration Page (admin panel > System > Configuration > Sales > Tax > AvaTax):
e UPC check: this field allows to disable or enable UPC functionality.
o If “disable” is set, then product SKU will be sent as ltemCode in Calculation and
Transaction Requests.
o if “enable” is set, additional field UPC attribute code appears:
m when UPC attribute code is empty, product SKU will be sent as
ItemCode in Calculation and Transaction Requests.
m If UPC attribute name is entered as UPC attribute code, it means that
product UPC will be sent as ltemCode in Calculation and Transaction
Requests.
To enable UPC functionality admin needs to:
1. Create new product attribute. To do it, go to Catalog > Attributes > Manage Attributes
and click “Add new Attribute” (it is also possible to use already created attribute).
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2. Add UPC attribute to attribute sets. Go to Catalog > Attributes > Manage Afttribute Sets.

Select Attribute Set and add newly created attribute to it (see picture bellow)

+) Back hl Id

Groups

Double click on a group to rename it

=155 General E
Egname }
(3 description
[3 short_description
Egsku
g weight
g news_from_date
Egnews_to_date
[ status
EJurl_key
@Visibilit}'

@ country_of_manufacture

Unassigned Attnibutes

=t -

= format

= frame_style

= gender L
= gendered

E genre

= jewelry_type i
= length

= lens_type

= luggage_size

= luggage_style

= luggage_fravel_style
= manufacturer

=] necklace_length

Egis_returnable

add attribute to attribute set

[E occasion
= shoe_size

= /5H Prices
3 giftcard_amounts
3 allow_open_amount
3 open_amount_min
3 open_amount_max
Eg price
Eggroup_price
g special_price -

= shoe_type
Esize

= sleeve_length
= upc —
Hstyle -

<

3. Create new product or edit existing one that is based on Attribute Set with added UPC
(admin panel > Catalog > Manage Products). Fill UPC attribute for product.

I_ Body Wash with Lemon Flower Extract and Aloe Vera (Home & Decor)

<) Back Hh‘le-,iih-.:- plicate | ..\- =

Customers Tagged Product ‘

Custom Options

SKU* sku-body-wash-with lemon [GLOBAL]
Weight * 1.0000 [GLOBAL]
Set Product as New from Date \ J [WEBSITE]
Set Product as New to Date [ = [WEBSITE]
Status * | Enabled v [WEBSITE]

fill UPC attribute for URL Key \body-wash-with-lemon-flower-extract-and-aloe-vera [STORE VIEW]

pmduu \ « Create Custom Redirect for old URL

upc (111111111111 [STORE VIEW]
Visibility * | Catalog, Search v [STORE VIEW]
Country of Manufacture \ v [WEBSITE]
Enable RMA [Use config 2 [WEBSITE]
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Now if UPC check is enabled and UPC attribute code is filled with UPC attribute, then
UPC value will be sent in Calculation and Transaction Requests as ItemCode.

Please note: UPC is sent as ItemCode only for product that has filled in UPC attribute. If
UPC attribute is not filled for product then product SKU will be sent in Calculation and
Transaction Requests. Also if you enable UPC check and enter UPC attribute code, product in
Order has empty value for UPC attribute the product SKU will be sent in Calculation and
Transaction Requests. So it is not possible to sent ItemCode without value; it will be filled in any
way.

Taxability based on UPC works regardless of shipping country and is actual for the
following cases:
tax estimation on Shopping Cart (no matter what product types is added to Cart);
tax calculation on single checkout (for guests and logged in users);
tax estimation on multiple checkout;
Transactions for Invoices;
Transactions for Credit Memos.

Tax Classes

The main purpose of Tax Classes is to configure special rules for tax calculation or
exempt customers from tax.
Admin can configure the following Tax Classes:
> Customer Tax Classes. To configure it go to Admin Panel > Sales > Tax > Customer
Tax Classes, open existing Customer Tax Class or create new one and enter standard

Avatax code to the field ‘AvaTax Code’.

Customer Tax Classes

Page 1 of 1 pages | View (20 v perpage | Total 6 records found

\‘ AvaTax Code Class Name

A General
Members Only
Not Logged-in
Private Sales
Retail Customer

Wholesale Customer

Valid values for Customer Tax Classes are:

° A - Federal Government
° B - State/Local Govt.

° C - Tribal Government
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° D - Foreign Diplomat

° E - Charitable Organization
o F - Religious/Education

. L - Other

o N - Local Government

° R - Non-resident (Canada)

See AvaTax 16 APl documentation to find more information about standard avatax
codes.
Pay attention that configured Tax Class may be applied to any Customer Group (admin

panel > Customers > Customer Groups).

& Customer Groups L- i SRR o |
Page 1 of 1pages | View 20 v perpage | Total 5records found m
D [ Group Name \ Tax Class

1 General General

0 NOT LOGGED IN Not Logged-in

5 Private Sales Member Private Sales

4 VIP Member Retail Customer

2 Wholesale Wholesale Customer

Customer Tax Class Code will be sent as defaultBuyerType in Transaction and
Calculation Requests.
> Products Tax Classes. To configure it go to Admin Panel > Sales > Tax > Product Tax
Classes, select any Product Tax Class or create new one and enter standard Avalara
code. The list of available codes you can find here.
Product Tax Classes

Page 1 of 1 pages | View |20 v perpage | Total 4 records found

AvaTax Code

/ Shipping (not used by AvaTax)

Special
b

Tax Exempt

[ class Name

BCTO00001

Taxable Goods

Then you should apply configured tax class to products: go to admin panel > Catalog >
Manage Products select any product (or create new one), open tab Prices and select

needed tax class for the field ‘Tax Class’.
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http://developer.avalara.com/wp-content/apireference/beta/?shell#header
https://help.avalara.com/000_AvaTax_Calc/000AvaTaxCalc_User_Guide/051_Select_AvaTax_System_Tax_Codes

Chosse Store View: I Plaid Cotton Shirt-Royal Blue-L (Clothing)

Default Values ¥ |
Prices
Product Information
Price * 160.00 [GLOBAL]
General o
- [UsD]
Prices B
Group Price Website Customer Group Price Action
e e [ © Add Group Pri |
Images ]
GLOBAL]
Recurring Profile Srecialbnte [GLOBALY
[UsD]
Design The Special Price is active only when lower than the
Gift Options Actual Price
Clothing Special Price From Date = [WEBSITE]
Inventory Special Price To Date [ = [WEBSITE]
Websites Tier Price Website Customer Group Qty Price Action
Related Products "
Apply MAP Use config v [WEBSITE
Up-sells .
isplay v WEBSITE
Cross-sells Display Actual Price Use config w
Erocdic L Revitws Manufacturer's Suggested Retail [GLOBAL]
Price [USD]
Product Tags
Tax Class * \ Special v [WEBSITE]

Customers Tagged Product

Custom Options

Product Tax Class Code will be sent as avalaraGoodsAndServicesType in
Calculation and Transaction Requests.

> Tax Class for Gift Options. To configure it go to admin Panel > System > Configuration
> Sales > Tax > Tax Classes > Tax Class for Gift Options and enter any tax class. Tax
Class Code will be sent as avalaraGoodsAndServicesType in Calculation and

Transaction Requests for Gift Options Items.

Limit tax calculation requests

Magento AvaTax extension allows to limit tax calculation requests.
To configure limitation of tax calculation requests go to Admin Panel > System >

Configuration > Sales > Tax > Avatax > Limit tax calculation requests.
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Limit tax calculation requests

Limit tax calculation requests an Enable v

CneStep checkout Pay Attention. If any custom checkout (like OneStep
Checkout) or some modification is used, this may not
work properly and is recommended to be disabled.

Limit tax calculation requests on Enable r
Multi-Address Checkout

Disable tax calculation requests Enable r
on non-checkout actions

This section provides next options:

The first setting limits Calculation requests on OnePage checkout. If this option is
enabled, tax will be estimated just before Order Review step and Calculation requests will be
reduced from 3 to 1 for default checkout flow.

The second setting has the same behavior and number of Calculation requests in this
case will be equal to quantity of addresses used. For example: for 2 addresses used in
checkout, Avatax will send only 2 Calculation requests, instead of minimum 5.

The third setting disables Calculation requests on the next actions

(‘catalog/category/view', 'customer/account/index’)

Error Handling

Error Handling allows to set up system behavior and control error messages in case
when tax cannot be calculated. This setting makes sense only when Validation: disabled. If
Validation is enabled, then Action on Error is ignored.

To set up Error Handling go to Admin Panel > System > Configuration > Sales > Tax >

Avatax: Error Handling.
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Error Handling [STORE

Action on Error Allow checkout without charging tax (no errorn » (=1 URE

Frantend Errar Message Unfortunately, we could not calculate tax for your [STOR

arder. PFlease try again with a different address or
contact us to complete your order.

A

T

Backend Error Message There was an errar getting tax rates fram Avalara. [STORE

Maotification Toolbar Enable r [GLOBAL]

Flease see the error log for details.

If there are issues syncing invoice or credit memo
data, show warning in admin notific ation toolbar.

Admin can configure the following settings:

> Action on Error: it controls system behavior when tax cannot be calculated. Pay

attention that Action on Error has lower priority than Validation and Normalization

settings so if you prefer to use Action on Error please disable setting under “Shipping

Address Options” block in AvaTax Configuration Page.

Admin is able to select one of two available values for Action on Error:

o

Disable checkout and show error message. When user enters non taxable
Shipping Address, error message is displayed and user is not able to go to the
next Checkout Step. In case when Validation is set to “Enable+Allow order” and
non-taxable address is provided, user is able to complete the checkout without
charging tax. If user calculates tax in Estimation block of Shopping Cart then
error message is displayed

Allow checkout without charging tax (no error message). This setting blocks
Validate Request: it is not sent during placing Order. After entering non taxable
Shipping Address, user is able to go to the next Checkout Step and place Order.
If user calculates tax in Estimation block of Shopping Cart then error message is
not displayed and user is able to go to Checkout. Pay attention that if Validation
is set to “Enable+Prevent Order” then user will not be able to place Order with

non taxable address - error message will be shown.

> Frontend Error Message: this message is displayed on StoreFront (Shopping Cart and

Checkout) if tax cannot be calculated
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> Backend Error Message: this message is displayed when admin places an Order and
tax cannot be calculated
> Notification Toolbar: this will be displayed on all admin pages if there are any errors

with items in the Queue (like admin messages).

- - Global R d S h Logged in as admin | Monday, November 30, 2015 | Log Out
Magento Enterprise ceel 99 Y >

Dashboard I Sales Catalog Customers Promotions Newsletter CMms Reports System @ Get help for this page

w One or more of the Cache Types are invalidated: Page Cache, Blocks HTML output. Click here to go to Ca via nent and refresh cache types.

Latest Message: Magento 2.0 Is Now Available! Read Ails You have 10 critical. § major. 19 minor and 65 notice unread message(s). G
@) AvaTax: There are 2 entries in the AvaTax Order Sync Queue that have errored. Syncing is attemped 5 times before permanently failing. I Go to the Ay
When Notification Toolbar: enable, then message displays in
admin panel if there are any errors with items in the Queue

Page 1 of 1 pages | View 0 per page | Total 19 records found h[,v r Queu :I o i hu‘i-:--ﬁi.&v'l. ov Jh as ﬁ'\,i h‘:,— 'Ii

[ AvaTax Order Sync Queue

Queue Id Store Id Entity Id Entity Increment Id Type Status Attempt Message Created At Updated At
From: From: From: | From: v v  From: From: J From: ﬂ
To: To: To: To: ool T To: & 1| To: = i
1 1 43 140000261 Invoice Complete 1 Nov 26, 2015 4:26:08  Nov 26, 2015 4:26:28
AlM AM
2 1 8 140000261 Credit Complete 1 Nov 26, 2015 4:26:15  Nov 26, 2015 4:26:29
memo AM AM
3 1 44 140000262 Invoice Complete 1 Nov 26, 2015 8:44:54  Nov 26, 2015 8:45:37
AM AM
4 1 9 140000262 Credit  Complete 1 Nov 26, 2015 8:45:01  Nov 26, 2015 8:45:38
memn AR AR il

You can read more about Queue on Order Sync Queue Page.

Be Astounding

astoundcommerce.com



Filter Requests

Filter Requests allow to calculate tax and validate address only for some Countries /
States / Provinces. Because of Filter Requests settings it is possible to decrease number of
Requests to Avalara by filtering Shipping Addresses. If Shipping Address is filtered then Filter
log is displayed instead of Validate, Calculation or Transaction Logs.
Go to Admin Panel > System > Configuration > Sales > Tax > Avatax: Connection
Settings to configure Filter Requests.
Admin is able to configure the following settings:
> Taxable Country: select countries to be taxable
> Filter Requests by Region: this allows admin to select one of the following values:
o None: Validation / Normalization and Tax Calculation is performed for all
countries specified under Taxable Country field
o Filter tax calculations: Tax calculation and reporting only occur for the regions
selected — address validation and normalization still occur for all transactions
o Filter tax calculations & address options: All types of Avatax 16 services
(Validation, Normalization, Tax Calculation) only occur for the regions selected
> Taxable Regions: this field appears only if Filter Requests by Region equals “Filter tax
calculations” or “Filter tax calculations & address options”. Taxable Regions allow to
control Avatax 16 Request only for selected regions.
Example #1:
Taxable Country: United States
Filter Requests by Region: None
In this case tax, validation and normalization will be performed for any US states. If user
selects Shipping Address with other country tax, validation and normalization will not be
performed.
Example #2:
Taxable Country: United States
Filter Requests by Region: Filter tax calculations

Taxable Regions: New York
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In this case tax is calculated only for New York state of US. Validation and Normalization
are performed for all states of US. So if user on StoreFront selects New Jersey state for
Shipping, Validation and Normalization are performed, but tax is not calculated. Filter log will be
displayed instead of Validation Log (Validation Request is not sent).

Example #3:

Taxable Country: United States

Filter Requests by Region: Filter tax calculations & address options

Taxable Regions: New York

In this case tax, validation and normalization will be performed only for New York state of
US. So Filter log is displayed instead of Validation, Calculation, Transaction Logs (Requests to
Avalara are not sent).

Filter log is not an actual request to Avalara; it is just notice that address was filtered.

See Logging to find more information about logs.
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Request Settings

Request Settings allow to decrease number Avatax 16 Requests by blocking Avatax 16
Process if StoreFront User tries to enter invalid data that is marked as ‘Prohibited’ in Admin

Panel.

Request Settings [STOR

m

Required Fileds prefix [STORE VIEW]
First Name
Middle Name
Last Mame
suffix
Full Address
Address

Field Rule -
Example: " -,

[¥5]

{

=}

m
T

To set up Request Settings go to Admin Panel > System > Configuration > Sales > Tax
> Avatax: Request Settings.
You can configure the following settings to activate Request Settings:
> Required Fields: if some field is selected, it means that value entered to equivalent field
of Shipping Address on Checkout should not be empty or should not be equal value from
Field Rule. Admin is able to select one or few Required Fields.
> Field Rule: value for Required Fields. Admin is able to enter one or few values via commas.
So user should be able to go to the next Checkout Steps only if Required Field in Shipping
Address is not empty and is not equal value from Field Rule.
Please note that entered Field Rule values work for all selected Required Fields so it is
impossible to specify different Rules for different Required Fields.
Request Settings are actual and make sense in case when Validation will be performed for
the Shipping Address. If shipping country or region is not selected as taxable and Validation is not

performed, then Request Settings Verification is ignored. See Filter Requests to find more

information about settings of taxable and non taxable countries.
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Example:

Required Fields: Company

Field rule: ' ,-, '

In this case, when user goes to checkout and enters / selects Shipping Address, system
verifies “Does the Company field is empty?”, “Does the Company field equal ‘ * (space), ‘-’ (dash) or

' (upper dash)?”. If answer for one of these questions is “Yes” then error message displays and

user is not able to go to the next Checkout Steps till he / she enters valid value for Company Code. If

error message is displayed then Requests for Validation and Tax Calculation are not sent.
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Logging

Data logging is used to collect information about any Avatax 16 actions or requests to
Avalara. Logs are saved to Avatax 16 Log table (Admin Panel > Sales > Tax > Avatax Logs).
To configure Logs go to Admin Panel > System > Configuration > Sales > Tax > Avatax :

Log & Queue Settings.

Log & CQueue Settings [STORE
Log Mode Log all actions (recommended) r [STORE
Log Entry Lifetime 3 [GLOBAL]

Required. Days before entries are auto-purged.

Successful Queues Lifetime i [GLOBAL]

Required. Days before entries are auto-purged.

Failed Queue Lifetime 60 [GLOBAL]

Required. Days before entries are auto-purged.

Log Type Ping [GLOBAL]

Calculation
Transaction
Filter
“alidate
Cueue

xport Queue [GLOBAL]

Admin is able to configure the following Logs Settings:
> Log Mode: admin is able to choose what logs should be saved to table. There are three
available values:
o Log only errors: it means that only logs with Level “Error’ will be saved.
Successful entries will be ignored
o Log all actions (recommended): all Errors and Successful Logs will be saved to
Avatax Log table

> Log Entry Lifetime: Records in the Log are automatically deleted after time period

specified
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> Log Type: only selected log types will be saved to Logs table. Not selected logs Types
will be ignored and will not be saved to table.
There are 6 Logs Types:

> Ping: it is not Request to Avalara; it is a log that says about Avatax 16 configuration
changes. Every time when admin saves Avatax 16 extension changes, log Ping is saved
to Logs table. if Avatax 16 is saved with invalid configurations then Level of Ping Log is
“Error”; if Avatax 16 is saved with valid configurations, Ping displays with level “Success”

> Calculation: it is a request to Avalara. Every time when tax for Order needs to be
calculated Calculation request is sent and appropriate log is saved to Log table. If tax
can be calculated by Avalara and its value is sent in Response, then Calculation Log
displays with Level “Success”. If tax cannot be calculated and error is sent in Response,
Calculation is saved with Level “Error”

> Transaction: it is request to Avalara. It works similar to Calculation but Transaction
Request is related to Invoice and Credit Memo. Transaction is sent when tax for Invoice
or Credit Memo needs to be calculated.

> Validate: it is a request to Avalara to validate and normalize shipping address. Validate
request is sent with Shipping Address; normalized Shipping Address is returned in
Response. Validate log displays with Level “Success” if Avalara can validate / normalize
shipping address; if error message instead of normalized Shipping address is sent in
Response then Validate log is saved with level “Error”

> Filter: it is not request to Avalara. It is just log that is displayed when tax or validation /
normalization cannot be performed because of Request Settings. If Shipping Address is
filtered and tax or validation / normalization cannot be performed, log Filter displays.

Filter log can be displayed with only “Success” Level. See Filter Requests to get more

info.

> Queue: it is a log not Request to Avalara. When Queue log presented in table it means
that any operation with Invoice / Credit Memo were performed: adding Invoice / Credit
Memo to Avatax Order Sync Queue table; sending Invoice / Credit Memo from Avatax
Order Sync Queue table to Avalara admin; deleting Queue entries from table.
Avatax Action Log table consists of the following columns:

> Log Id: it is the log sequence number

> Store Id: identification number of store which Avatax 16 operation or request was

performed from.
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> Level: it indicates successful or failed logs / requests. If Avatax 16 operation or request
is successful then log displays with Level “Success”; if error display in Response and
operation is unsuccessful then Log Level is “Error”.

> Type: Avatax 16 operation or request name is displayed (log types were described
previously)

> Created At: date when Log / Request is created / send

To see table with logs go to Admin Panel > Sales > Tax > AvaTax Log.

] AvaTax Action Log

Page 1 v| of 11pages | View |20 v | per page | Total 209 records found m

["Logd | storeld Level Type Created At

From: From: v v || From: ||

To: To: To: [
209 1 Success Queue Dec 7, 2015 1:43:47 AM
208 1 Success Transaction Dec 7, 2015 1:43:47 AM
207 1 Success Queue Dec 7, 2015 1:43:28 AM
206 0| Success Ping Dec 7, 2015 1:40:42 AM
205 1 Success Calculation Dec 7, 2015 1:25:43 AM
204 1 Success Calculation Dec 7, 2015 1:25:42 AM
203 1 Success Validate Dec 7, 2015 1:25:40 AM
202 1 Success Validate Dec 7, 2015 1:25:40 AM
201 1 Success Calculation Dec 7, 2015 1:25:32 AM
200 1 Success Filter Dec 7, 2015 1:21:37 AM
199 1 Success Queue Dec 6, 2015 11:29:06 AM
198 1 Success Transaction Dec 6, 2015 11:29:06 AM
197 1 Success Queue Dec 6, 2015 11:29:06 AM
196 1 Success Transaction Dec 6, 2015 11:29:06 AM
195 1 Success Queue Dec 6, 2015 11:29:02 AM
194 1 Success Queue Dec 6, 2015 11:29:02 AM

Any log contains Request, Response and Additional information block.
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Array
{
[hasError] ==
[headar] == Array
{

[accountld] == 1221 lceb-ceaa-4858-Be 10-32248=8 123546
[companyCode] == ASTOUND

[transactionType] == Sale

[documentCode] == quote-2656-2015-12-07
[eustomerCode] == Test User (143}

[transactionDate] == 2015-12-07

[eurrency] == USD

[defaultLocations] == Aray

[ShipFrom] == Amay
{
[taxLocationPurpose] == ShipFrom
[address] == Armray
{

[lingt] == _
[lin=d] ==
[eiy] =>
Istate]l == (&

Array
{

[hasErmar] ==
[header] == Array
|

[accountld] == 12213cebocaadBobie 1002248812540
[companyCode] == ASTOUND
[transactionType] == sale
[documentCode] == quote-2858-2015-12-07
[customerCode] == Test User {143}
[transactionDate] == 2015-12-07
[eurrency] == USD
[totalTaxCverrideAmount] == 0
[taxCaleulationDate] == 2015-12-07
[defaultLocations] == Amay

[shipFrom] == Array
{
[address] == Amray
{
[line1] == _

[state] == CA
[ nrouinns] == A

Additional

Admin is able to Export Logs table with all existing records in it. To do this go to Admin

Panel > System > Configuration > Sales > Tax > Avatax > Log & Queue Settings > Export Logs)
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Order Sync Queue

All Orders can be transferred to Avalara admin with the purpose to formulate reports and

detailed statistics. To sync with Avalara admin panel, Invoice or/and Credit Memo should be

created for Order.

Invoices and Credit Memos that are prepared for sending to Avalara admin are collected

into Order Sync Queue table.

To configure TNG Order Sync Queue go to Admin Panel > System > Configuration >

Sales > Tax > Avatax > Action: enable: calculate tax, submit data

To see Queue table go to Admin Panel > Sales > Tax > AvaTax Order Sync Queue.

(5] AvaTax Order Sync Queue

Page 1 of 1 pages | Wiew |20 v | perpage | Total 6 records found
Queue Id Store Id Entity Id Entity Increment id Type
From: From: From: From:

To: To: To: To:
1 1 43 160002556  Invoice
2 1 44 160002557 Invoice
3 1 45 160002558 Invoice
4 1 8 160002556 Credit memo

5 1 46 160002559 Invoice

=
o

160002557 Credit memo

Status

Complete

Complete

Complete

Complete

Pending

Pending

Attempt
¥ | From:
To:

Message

Created At

From: |

To: [F

Dec 7, 2015 7:56:01
AM

Dec 7, 2015 7:59:48
AM

Dec 7, 2015 9:03:22
AM

Dec 7, 2015 9:03:27
AM

Dec 7, 2015 9:03:47
AM

Dec 7, 2015 9:03:53
Al

Updated At

From: 3|

To: [F]

Dec 7, 2015 8:05:03
AM

Dec 7, 2015 8:05:04
AM

Dec 7, 2015 9:03:31
AM

Dec 7, 2015 9:03:32
AM

Dec 7, 2015 9:03:47
AM

Dec 7, 2015 9:03:53
AM

When Action is "enable: calculate tax, submit data" Invoices/Credit Memos are

automatically sent to AvaTax Order Sync Queue table after its creation. When Invoices / Credit

Memos are presented in Queue table they can be sent to Avalara admin by clicking "Process

Queue Now" button on tab "Avatax Order Sync Queue". In this case all data from Avatax Order

Sync Queue is delivered to Avalara Admin.

There are 5 different statuses of Orders/Invoices/Credit memos:

1. Pending: all Invoices / Credit Memos are sent to Order Sync Queue table with statuses

"Pending". Pending status means that Invoice / Credit Memo is new and it is not present

in Avalara Admin.

2. Retry Pending: when admin tries to send Invoices / Credit Memos to Avalara Admin but

attempt is unsuccessful, Invoices / Credit Memos are returned with status "Retry

Pending". Reasons of unsuccessful attempt:

a. order is placed with non taxable address;
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b. AvaTax is saved with invalid Connection Settings;
c. Invoices / Credit Memos IDs already exist in Avalara admin.

Invoices / Credit Memos can be returned with statuses "Retry Pending" four times.

When Retry Pending Queue is sent fifth time and attempt is unsuccessful, then Queue

returns with status "Failed".

3. Failed status means that Invoices / Credit Memos are sent to Avalara Admin fifth time
and no one attempt is successful.

4. Unbalanced. Since tax rates and configurations can change, the tax amount of orders
can also change from the time the customer checks out and when orders are invoiced. If
this happens, items in the queue will change to Unbalanced status and the difference
will be recorded. Magento will continue to use the old amount (since that is what you
collected from the customer) and the AvaTax dashboard will show the correct amount to
be paid to the respective jurisdiction.

Example: To make status of Invoices / Credit Memos Unbalanced you should:

a. place order on StoreFront;

b. open order as admin (admin panel > Sales > Orders);
c. change Shipping Address to new one;

d. create Invoice/Credit Memo for Order;

e. send Queue to Avalara Admin.

5. Complete. When Invoice / Credit Memo is successfully sent to AvaTax admin console, it
returns with status "Complete".

When Invoice / Credit Memo is created, it is automatically sent to Queue, Log "Queue"
creates in Log table (admin panel > Sales > Tax > Avatax Logs). Queue is not a request; it is
just log that indicates fact about Queue process.

When Invoice / Credit Memo is sent to Avalara admin, Logs "Queue" and "Transaction"
are created in Log table.

To delete Queue with statuses "Complete", "Failed", "Unbalanced" manually, you can click a
button "Clear Queue Now". When admin deletes Queue, log “Queue” creates.

Admin is able to set up the following configuration to delete Queue automatically (Admin
Panel > System > Configuration > Sales > Tax > Avatax > Log & Queue Settings):

> Successful Queue Lifetime: Successful queue entries (Invoices / Credit Memos with

statuses "Complete") are automatically deleted after time specified.
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> Failed Queue Lifetime: Invoices / Credit Memos with statuses "Failed" and

"Unbalanced" are automatically deleted after time specified.
Admin is able to Export Queue with all existing records in it. To do this go to Admin

Panel > System > Configuration > Sales > Tax > Avatax > Log & Queue Settings > Export

Queue).
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List of hidden and overridden settings

When Avatax is installed and enabled, some default Magento settings are hidden and

their behaviour is overridden.

System > Configuration > Sales > Tax > Tax Classes section

e Tax Class for Shipping - Set to Default Avatax shipping code FR020100

System > Configuration > Sales > Tax > Calculation Settings section

e Tax Calculation Method Based On - Set to Total

e Tax Calculation Based On - Set to Shipping Address

e Shipping Prices - Set to Catalog Prices value

e Apply Customer Tax - Hidden when Catalog Prices = Exclude Tax and set to After
Discount

e Apply Discount on Prices - Set to Catalog Prices value

e Apply Tax On - set to Custom price if available

e Enable Cross Border Trade - set to Yes when Catalog Prices = Include Tax and to No

when Catalog Prices = Exclude Tax

System > Configuration > Sales > Tax > Price Display Settings section
e Display Product Prices - Set to Catalog Prices value
e Display Shipping Prices - Set to Catalog Prices value

Sales > Tax

e Manage Tax Rules
e Manage Tax Zones & Rates

e Import/ Export Tax Rates
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