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About Avatax extension 

Avalara Avatax is well known platform that dynamically delivers instantaneous sales tax                       

decisions based on precise geo-location. Tax can be calculated for almost all countries in the                             

world. You don't need to create or rewrite tracking zones, rates, tax rules. AvaTax continuously                             

updates data, making accurate sales tax calculations available immediately in real time. Avatax                         

extension performs address validation and normalization, looks for taxability determination,                   

uses jurisdiction assignment technology for correct and valid tax calculation. 

The main purpose of the extension is to calculate tax with Avalara Avatax Platform. A lot                               

of settings allow to configure extension regarding to specifics of your stores, products, clients.  

All Avatax operations and requests are saved as logs in a table so admin can review and                                 

use existing information for own and business goals. 

Avatax extension is easy installed to Magento platform and can be configured differently                         

for all available stores. If Avatax extension is disabled for any store, tax can be calculated by                                 

using other services (for example, Default Magento Rules). 

 

Flow and integration with StoreFront 

Every time when tax need to be calculated (on Shopping Cart, Checkout) and record sale                             

(Invoice/Credit Memo) for filing and reporting in Avatax system Avatax extension starts its                         

work. 

GetTax is an Avatax request to calculate tax for Order or record sale (Invoice/Credit                           

Memo) for filing and reporting in Avatax system. 

Validate is an Avatax Request to validate and normalize Shipping Address. 

Filter is a log that is created to indicate situation when GetTax/Validate cannot be                           

performed for entered Shipping Address because of admin settings for Filter Request (admin is                           

able to select countries and regions which validation and tax calculation should or should not be                               

performed for). If Shipping Address is filtered then GetTax/Validate is skipped.  

 



Invoices and Credit memo can be transferred to Avalara admin. Queue is used for this                             

purpose. So when Queue transaction is performed, log Queue is created. 

See Avatax work-flow on diagram bellow. 

 

 

Installation 

Typical Installation Process 
 
In addition to the instructions below, you can watch this installation walkthrough video that 
shows the complete installation on a Magento Community 1.9.3.6 website. 

 
1. Even though AvaTax extension is open source, to be able to install it you need to go 

through purchase process, which is described below. 
1.1. Browse to  Magento Marketplace https://marketplace.magento.com. 
1.2. Sign in. 
1.3. Then, purchase AvaTax extension to be able to obtain extension installation key. 
1.4. To obtain installation key, please, browse to your account profile. 
1.5. Switch to to My Access Keys and choose Magento 1 tab as shown below: 

 

https://astoundcommerce.com/magento-extensions/avatax/screencasts/typical-installation-process-20171019.mp4
https://marketplace.magento.com/


 
1.6. Find your personal access key that relates to Avalara Sales Tax Automation 

product. 

 
 

2. Continue with your magento website. 
2.1. Login as administrator to magento admin panel. 

 



2.2. If applicable, disable caching (System > Cache Management) and disable 
compilation (System > Tools > Compilation) 

2.3. Install extension with Access Key. 
2.3.1. Browse to System > Magento Connect > Magento Connect Manager and 

Log in 
2.3.2. Change to the Settings tab and set Preferred State to "Beta", then click 

Save Settings 
2.3.3. Change to the Extensions tab, paste in the Extension Key input Product 

Access Key, that you gained with instructions above, then click Install, and 
confirm that you are shown a success message. 

2.3.4. Click Refresh to see the package successfully installed 
2.3.5. Click Return to Admin in the upper right 

2.4. Flush permissions: Log out of the admin and log back in 
2.5. Enable the cache, turn compilation back on, and recompile if you were previously 

using those features 
 

Installation Process for Legacy Versions of Magento Professional & Magento Enterprise 
 

1. If applicable, disable caching (System > Cache Management) and disable compilation 
(System > Tools > Compilation) 

2. Download the latest version. It can be obtained via Magento Marketplace. 
3. Extract the contents: Confirm the creation of:   

a. /app/etc/modules/OnePica_AvaTax.xml 
b. /app/code/community/OnePica/AvaTax/  

4. Enable cache, turn compilation back on, and recompile if you were previously using 
those features 

Connection Settings 

To set up Avatax extension go to Admin Panel > System > Configuration > Sales > Tax >                                   

Avatax: Connection Settings 

 



 

To connect Avatax extension you should enter valid credentials: 

➢ URL: URL of Avalara Service that will provide tax calculation and address validation /                           

normalization options. 

➢ Account Number: this string is a UUID issued by Avalara to identify the Avalara account                             

that owns the company identified by the Company Code. 

➢ Key: the Authorization is used to identify the actor (person or system) making the                           

request. 

➢ Company Code: identifies the company profile/legal entity with which the Avatax                     

operations are associated. [Get Companies] button allows to fill list of available company                         

codes if  credentials are valid.  

To enable or disable AvaTax please use Action setting under Connection Setting block: 

 



➢ Disable: tax will be calculated by default Magento; AvaTax is disabled. Default Magento                         

settings for tax calculation are present. Please note, that in case Avatax is disabled for                             

one or few Store Views on the web site, tax will be calculated by native Magento                               

functionality. So it's possible to enable AvaTax extension for some of the Store Views                           

and disable it for the other Store Views. 

➢ Enable: calculate tax: only tax for Orders is calculated by Avatax. Default Magento                         

settings for tax calculation are not present. Invoices and Credit Memos are not sent to                             

Avalara admin, GetTax requests are not created for Invoice or Credit Memo creation. 

➢ Enable: calculate tax, submit data: tax is calculated for Orders; Invoices and Credit                         

Memos are sent to Avalara Admin console with Uncommitted status.  

➢ Enable: calculate tax, submit data and commit: tax is calculated for Orders; Invoices and                           

Credit Memos are sent to Avalara Admin console with Committed status. 

Each time when admin makes some changes in Avatax settings (not only Connection                         

Settings but settings related to any Avatax option) Ping log is saved to Avatax Log table (Admin                                 

Panel > Sales > Tax > Avatax Logs): 

➢ if all connection settings are valid Avatax extension saves Ping Log with Level                         

“Success”; 

➢ if at least one Connection Parameter is invalid Avatax extension saves Ping Log with                           

Level “Error”. 

See Logging find more information about Logs. 

User is able to configure Filter Requests by Region option, go here to see how to do it. 

➢ Detail Level: Defines what detail level will be send to Avalara. For “Line” detail level 
calculated product tax rate will be used from tax line. For “Tax” detail level  product rate 
will be effective and collected for each product by jurisdiction. 

 

Validation & Normalization 

For tax calculation process, Address Validation should be performed. 

Address Validation is the process that is used to check the validity and deliverability of a                               

physical mailing address. The main purpose of Validation is to verify whether address is valid                             

and really exists.  

 



Address Normalization is process of changing address entered by user to full and                         

well-formed.  

To configure Validation and Normalization of address go to Admin Panel > System >                           

Configuration > Sales > Tax > Avatax > Shipping Address Options 

 

 



Admin is able to configure the following Shipping Address Options: 

➢ Address Validation: This optional step stands for recognition of address before tax                       

calculation. Admin is able to select one of the following values:  

○ Disabled: a basic level of validation is performed to verify that AvaTax can                         

calculate tax on the given address 

○ Enabled + Allow Order: if non-taxable address is entered tax is not calculated but                           

user is able to continue and place order. 

○ Enabled + Prevent Order: the user should enter a valid shipping address on                         

Shopping Cart or Checkout to continue. If non-taxable address is entered, error                       

message is displayed and user is not able to proceed. 

See Error Handling article to set up the most flexible behavior.  

➢ Address Normalization: this optional step is used to replace address entered by user                         

with a well-formed address provided by AvaTax during checkout. Two values are                       

available: 

○ Disabled: normalized address is sent in Response block of Validation but this                       

address is not used on Checkout 

○ Enabled: normalized address is used on Checkout instead of address entered by                       

user 

➢ Onepage Checkout Address Normalized Notice: this message is displayed if address                     

has been modified during validation process and is replaced with address entered by                         

user on Onepage Checkout (Address Normalization should be enabled) 

 

https://docs.google.com/document/d/1SRBACjUXf7LujHzXaFq2Ec9KbcAtKh_G6iPhgzI_-lA/edit#heading=h.hmekw4k5opdk


 

 

➢ Multi-Address Checkout Address Normalized Notice: applies only if address                 

normalization is enabled. Message is shown if address that has been entered by user on                             

Multiple Checkout is modified and this modified address is used on Checkout                     

 

➢ Multi-Address Address Validation Error: applies only if address validation is enabled.                     

Message is shown on Multiple Checkout if address is invalid. You can use ‘%s’ in your                               

error message text; in this case ‘%s’ will be replaced with shipping address.                       

 



Pay attention that address can be normalized only when Validate Request has Success                         

Level.  

➢ Website owner could allow customers to disable address normalization during checkout                     

process. Customer can disable option appears if Address Normalization is enabled.

 



if this option turned on then customer have ability to control if normalization applies to                             

address via checkbox, as shown on screenshot below             

If customer clicks disabler checkbox then addresses would be reloaded without                     

normalization applied immediately allowing customer to continue checkout process.                 

Customer also able to turn on normalization with switching off disabler checkbox.                       

Disabler checkbox and loader labels titles could be changed via fields in settings. 

 



 

To find more details about Address Validation process go here. 

Please note: if user proceeds to Checkout with products that don’t need shipping (virtual                           

or downloadable products, Virtual Gift Card Products), then Validation and Normalization is                       

performed for Billing Address. 

Tax Calculations 

Avatax extension uses GetTax Request type for two purposes:  

➢ process of tax calculation for Order. GetTax Request is sent when user estimates tax in                             

Shopping Cart or places Order. 

➢ record sale (Invoice/Credit Memo) for filing and reporting in Avatax system (see details                         

in Queue section). When Invoices / Credit Memo is sent from Avatax Order Sync Queue                             

table to Avalara admin, tax need to be calculated. GetTax is sent for this purpose. 

GetTax requests have following structure: 

- information about user: customer code, tax class, customer usage type, etc. 

- information about  transaction: date, transaction type, currency etc. 

- information about products: quantity, description, SKU, price, etc. 

- information about shipping: origin and destination addresses, price, special tax code,                     

etc. 

Response block of GetTax includes detail tax amount for each item and entire Order.                           

Response also contains jurisdiction details, tax types, comments etc. 

GetTax details while Cart and Checkout calculations 

GetTax Request is sent each time when data needed for tax calculation is changed. But                             

if request for changed data was sent previously, then new GetTax request is not sent, but data                                 

from previous response is used. It allows to decrease number of Requests. 

Example: Shopping Cart 

1. User adds product to Cart 

2. Enters Country, State and Zip Code 

3. Clicks “Estimate” 

Result: GetTax Request is sent 

 

http://developer.avalara.com/api-docs/designing-your-integration/address-validation


4. Selects Shipping Method with price that is higher than 0 

5. Clicks “Update Total” 

Result: New GetTax Request is sent 

6. Select Shipping Method with price that equals 0 

Result: New GetTax Request is not sent because the same request was sent after step                             

#3 

So few GetTax Requests can be sent during tax estimation in Shopping Cart or Checkout                             

- this is expected behavior. 

GetTax details while Invoice and Credit Memo calculations 

GetTax Request is sent once when Invoice / Credit Memo is sent to Avalara Admin with                               

either Uncommitted or Committed status, depending on Action configuration. Invoice / Credit                       

Memo changes status accorrding to GetTax Response (read more about Queue in Order Sync                           

Queue article).  

Only one GetTax Request is sent for one Invoice / Credit Memo per one processing                             

Queue. 

Business Identification Number 

Business Identification Number (Business Identification No) is also known as VAT                     

Registration ID.  

Business Identification No can be sent in GetTax Requests if it is specified by user                             

during order placing. Business Identification No is usually provided by customer along with                         

Shipping Address. But if user doesn’t specify it in Shipping Address and specifies it in Billing,                               

then Business Identification No is taken from Billing Address.  

To enable / disable displaying of Business Identification No on StoreFront go to Admin                           

Panel > System > Configuration > Customers > Customer Configuration > Create New Account                           

Options and set value for the field “Show VAT Number on Frontend”. 

 



Tax inclusive and exclusive prices 

Magento AvaTax extension is able to handle both tax inclusive and exclusive product                         

prices. Behavior is driven by Magento setting under Admin Panel > System > Configuration > Tax                               

> Calculation Settings > Catalog prices.  

 

Default value of Excluding Tax stands for tax calculations based on product prices in                           

Magento admin panel set without any tax, also called net prices. Below is an example of Order                                 

review page, as customers see it with Excluding Tax setting.                 

 

 



To calculate tax basing on gross price, meaning sale amount and tax being                         

back-calculated from product price, Catalog prices should be set as Including Tax. Below is                           

example of Order Review page in this case. 

 

 

 

Catalog prices option may be set on Website level. 

 

Magento Price Display Settings are hidden and are driven with Calculation Settings, 

meaning that prices on StoreFront catalog (categories, product details pages, etc.) are 

displayed as they are configured in admin panel, since tax for them is not calculated yet.   

 

In order to provide better user experience, different Display Settings are supported for 

Shopping Cart and Order, Invoices, Credit Memos views: They can be set as Including tax, 

Excluding tax or Including and Excluding tax. 

 



 

 

 

While Catalog Prices are set as Including Tax, Apply Customer Tax: Before / After                           

Discount configuration is available. It controls, whether GetTax requests are sent before or after                           

discounts are applied on prices.  

 

 

   

 



Effective tax rate vs ordinary tax rate 

It's regularly happens that some tax codes could have exemption for special                       

jurisdictions. Please review screenshot of such case below: 

 

If you have ordinary (Line) detail level configured then order item would be presented                           

with Tax Percent equal to 9.3%, as shown below : 

 

if you have effective (Tax) detail level configured then extension does not take into                           

consideration jurisdictions with exemptions and shows effective 3% rate in order item as shown                           

below : 

 

As you could see tax amount is the same in both configurations, difference is only in                               

rates representations. 

 



Data Mapping 

This is section for configuration additional parameters that are sent in GetTax Requests.                         

It impacts tax calculation process. 

To configure Data Mapping go to Admin Panel > System > Configuration > Sales > Tax >                                 

Avatax > Data Mapping. 

 

Admin is able to configure following parameters:  

➢ Customer Code Format: it is sent in CustomerCode line of Request Header. The                         

following values are available for selecting 

 



○ customer_id; 

○ customer_email; 

○ customer_name (customer_id). 

○ customer attribute: if you select this option the field Customer Code Format 
Attribute will appear. You should fill this field with code of customer attribute. 
The value of customer attribute will be sent in the request to Avalara. There is 
default Avatax Customer Code (avatax_customer_code) attribute that can be 
used as customer code. 

➢ Shipping Sku: entered value is sent in Request to identify Shipping Costs item 

➢ Gift Wrap Order Sku: SKU that is sent to denote gift wrap order costs (Gift Wrapping for                                 

Entire Order) 

➢ Gift Wrap Items Sku: SKU that is sent to denote gift wrap items costs (Gift Wrapping for                                 

Individual Items) 

➢ Gift Wrap Printed Card Sku: SKU that is sent to denote gift wrap Printed Card costs 

➢ Adjustment Refund Sku: SKU that is sent to denote positive adjustments 

➢ Adjustment Fee Sku: SKU that is sent to denote negative adjustments 

➢ Sales Person Code: the salesperson code for orders that is sent in Request Header 

➢ Location Code: the location code for orders; optional field 

➢ Reference Code 1, Reference Code 2: optional. An attribute code to pass with each                           

product (see product attributes in Catalog > Attributes). Admin should enter valid product                         

attribute to field that is sent in Request for products.  

➢ UPC check: detail information about this option you can find here. 

Pay attention that all parameters except UPC check, Reference Code 1 and Reference                         

Code 2 let users to fill in a static values. UPC check, Reference Code 1 and Reference Code 2                                     

can be mapped to dynamic fields.  

For example, if admin enters Location Code: 0000 it means that static value “0000” of                             

LocationCode will be sent for all GetTax requests. But if admin enters Reference Code 1: color it                                 

means that specific color of ordered item will be sent in GetTax requests. So Reference Code 1                                 

has dynamic value that changes according to item attribute value. 

 

Taxability based on UPC 
To manage taxability based on UPC admin is able to configure the following settings in                             

AvaTax Configuration Page (admin panel > System > Configuration > Sales > Tax > AvaTax): 

 



● UPC check: this field allows to disable or enable UPC functionality.  
○ If “disable” is set, then product SKU will be sent as ItemCode in GetTax requests.  
○ if “enable” is set, then additional field UPC attribute code appears: 

■ when UPC attribute code is empty, product SKU will be sent as ItemCode                         
in GetTax requests.  

■ If UPC attribute name is entered as UPC attribute code, it means that                         
product UPC will be sent as ItemCode in GetTax Requests. 

To enable UPC functionality admin needs to:  
1. Create new product attribute. To do it, go to Catalog > Attributes > Manage Attributes and                               

click “Add new Attribute” (it is also possible to use already created attribute).  
2. Add UPC attribute to attribute sets. Go to Catalog > Attributes > Manage Attribute Sets.                             

Select Attribute Set and add newly created attribute to it (see picture bellow) 

  
3. Create new product or edit existing one that is based on Attribute Set with added UPC                               

(admin panel > Catalog > Manage Products). Fill UPC attribute for product. 

 



 

 
 

Now if UPC check is enabled and UPC attribute code is filled with UPC attribute, then                               
UPC value will be sent in GetTax requests as ItemCode. 

Please note: UPC is sent as ItemCode only for product that has filled in UPC attribute. If                                 
UPC attribute is not filled for product then product SKU will be sent in GetTax Requests. Also if                                   
you enable UPC check and enter UPC attribute code, product in Order has empty value for UPC                                 
attribute the product SKU will be sent in GetTax requests. So it is not possible to sent ItemCode                                   
without value; it will be filled in any way. 

Taxability based on UPC works regardless of shipping country and is actual for the                           
following cases: 

● tax estimation on Shopping Cart (no matter what product types is added to Cart); 
● tax calculation on single checkout (for guests and logged in users); 
● tax estimation on multiple checkout; 
● Transactions for Invoices; 
● Transactions for Credit Memos. 

 

Tax Classes 

The main purpose of Tax Classes is to configure special rules for tax calculation or                             

exempt customers from tax.  

Admin can configure the following Tax Classes: 

 



➢ Customer Tax Classes. To configure it go to Admin Panel > Sales > Tax > Customer Tax                                 

Classes, open existing Customer Tax Class or create new one and enter Avatax code to                             

the field ‘AvaTax Code’. 

 

See AvaTax documentation to find more information about standard avatax codes. 

Pay attention that configured Tax Class may be applied to any Customer Group (admin                           

panel > Customers > Customer Groups).  

 

Customer Tax Class Code will be sent as CustomerUsageType in GetTax Requests. 

➢ Products Tax Classes. To configure it go to Admin Panel > Sales > Tax > Product Tax                                 

Classes, select any Product Tax Class or create new one and enter specific code from                             

Avalara admin panel, which needs to be created and configured there previously.   

 

Then you should apply configured tax class to products: go to admin panel > Catalog >                               

Manage Products select any product (or create new one), open tab Prices and select                           

needed tax class for the field ‘Tax Class’. 

 

http://developer.avalara.com/api-documentation/avatax-15-api/designing-your-integration/handling-tax-exempt-customers


 

Product Tax Class Code will be sent as TaxCode in GetTax Requests. 

➢ Tax Class for Gift Options. To configure it go to admin Panel > System > Configuration >                                 

Sales > Tax > Tax Classes > Tax Class for Gift Options and enter any tax class. Tax Class                                     

Code will be sent as TaxCode in GetTax Requests for Gift Options Items. 

 

Limit tax calculation requests 

Magento AvaTax extension allows to limit tax calculation requests.  

To configure limitation of tax calculation requests go to Admin Panel > System >                           

Configuration > Sales > Tax > Avatax > Limit tax calculation requests. 

 

 

 



This section provides the following options:  

The first setting limits GetTax requests on OnePage checkout. If this option is enabled,                           

tax will be estimated just before Order Review step and GetTax requests will be reduced from 3                                 

to 1 for default checkout flow. 

The second setting has the same behavior and number of GetTax requests in this case                             

will be equal to quantity of addresses used. For example: for 2 addresses used in checkout,                               

Avatax will send only 2 GetTax requests, instead of minimum 5. 

The third setting disables GetTax requests on the following actions                   

('catalog/category/view', 'customer/account/index'). 

Be aware, that functionality may work incorrectly if any custom checkout (like OneStep                         

Checkout) or some modification is used. It is recommended to disable limit tax calculation                           

requests options in this case.  

 

Tax calculation settings 

AvaTax Magento extension has 3 options of tax calculation settings configuration. Overridden 
settings are hidden and can't be changed in Magento admin panel. 

Configuration options: 

1. Catalog Prices = Excluding Tax 

overridden settings: 

a. Apply Customer Tax = After Discount 
b. Shipping Prices = Catalog Prices value (Excluding Tax) 
c. Apply Discount on Prices = Catalog Prices value (Excluding Tax) 
d. Enable Cross Border Trade = No 

 

2. Catalog Prices = Including Tax and Apply Customer Tax = Before Discount 

overridden settings: 

a. Shipping Prices = Catalog Prices value (Including Tax) 
b. Apply Discount on Prices = Catalog Prices value (Including Tax) 
c. Enable Cross Border Trade = Yes 

 

3. Catalog Prices = Including Tax and Apply Customer Tax = After Discount 

overridden settings: 

 



a. Shipping Prices = Catalog Prices value (Including Tax) 
b. Apply Discount on Prices = Catalog Prices value (Including Tax) 
c. Enable Cross Border Trade = Yes 

 

The following option is not currently supported: 

● Catalog Prices = Excluding Tax and Apply Customer Tax = Before Discount 

 

Other options are overridden and hidden because in these cases it will be necessary to send a 
huge number of additional requests to Avalara servers.  

Custom Duty 

System Configuration 
You could find AvaTax Customs Duty configuration if you browse to  
admin -> System / Configuration -> SALES / Tax -> AvaTax Customs Duty Calculator section 
under AvaTax section. 
Configuration : 

➢ Action. You able to Enable / Disable tax calculation that supports Customs Duty feature. 

 

 



 
➢ Shipping Insurance Sku. This field contains insurance sku for requests. Please, do not 

change value without crucial reason. 
➢ Shipping Insurance Tax Code. This field contains Avalara insurance tax code. Please, do 

not change value without crucial reason. 
➢ Express Shipping Methods. Customs Duty also accepts express parameter for shipping 

methods. You could choose whether methods are express or not. 
➢ Shipping Mapping. Customs Duty accepts few types of shipping (ground, air and sea) as 

optional parameter that allows to calculate Customs Duty more accurate. This section 
allows you to map each shipping method that exists in your system to particular 
Customs Duty shipping type 

 
 

HS Codes 
HS Codes used by Avalara during import duties calculations. These codes represent group of 
products and they are international. You could identify HS Code for each of your product if you 
browse to Avalara website (https://www.avalara.com/hs-codes/). 
To create HS Code group in AvaTax, please browse to admin -> AvaTax / AvaTax Customs Duty / 
HS Code Groups. 
 
 

 
 
 
Code Information tab 
HS Code Group Name field, you have to fill it with at least 6 numbers that identify set of 
products. Please, enter Description as well, that will help you to identify what stands for HS 
Code. 
 
 

 

 



Tab HS Codes for Countries 
This tab represents list of codes by countries, here you need to enter full code with last few 
numbers and link that code with countries where it is used. Please, review screenshot below. 
 

 
 

Parameters 
Parameters is important part of import duties calculations. Different countries apply duties 
based on the amount of product crossed the border. You could find pre-installed parameters if 
you browse to admin -> AvaTax / AvaTax Customs Duty / Parameters. 
 

 
 
Currently Avalara supports only grams and kilograms in customs duty calculations. If Avalara 
supports more parameters you could easily add them here knowing Avalara Code, Type and 
countries where this parameter is used. 
 
 

Agreements 
Some countries sign agreements to remove or reduce import duties. 
If you browse to admin -> AvaTax / AvaTax Customs Duty / Agreements you could find 
agreements installed by default. Currently Avalara supports only NAFTA agreement. Perhaps, 
there will be more agreements in future and you could easily add them here. 
 
 

 



Product Configuration 
You should perform Customs Duty configuration per product. Each product edit page contains 
AvaTax Customs Duty tab. Please, review screenshot below.  
 
 

 
➢ To apply Customs Duty calculation you need at least to configure HS Code Group for 

product. Then AvaTax during calculation will choose full HS Code depending on shipping 
destination country.  

➢ You can setup Weight units, for ex. Kilogram, that will be used for tax estimation. 
Parameter dropdown will contain the configured units of measurement at admin -> 
/Avatax / Avatax Customs Duty / Parameters page. It should be noted that Avalara 
currently does not support any conversion between units, so if you will try to send 
pounds while calculating import duties for Germany, Avalara will return error.  Also two 
unit of measurement (for ex. Kilogram and Gram) with the same type (ex. “Mass”) 
should not be defined for the same product when these units of measurement are 
configured for the same countries. 

➢ Under Parameter configuration you also could see Agreements list. Here you could 
configure the agreements, which are supported for the product. 

 

Seller is an importer flag 
Commonly seller configures countries for which he is willing to manage import duties on 
Avalara side. AvaTax on the other hand has flag that allows to force Avalara to include import 
duties into grand totals or return them as notification message. 
“Seller is an importer” flag has three states : 

➢ empty (Avalara configuration is used during calculations) 
➢ Yes (import duties are included into grand totals, Avalara configuration is overridden) 
➢ No (import duties are not included into grand totals, Avalara configuration is overridden) 

 



You could find and use this flag: 
➢ for customer permanently if you browse to admin -> Customers / Manage Customers -> 

Edit -> Account Information. 

 
➢ or during order creation via admin panel, where this flag has higher priority. 

 
   

 



Import duties configuration 
You could choose for which countries you want to collect customs duty taxes if you browse to 
Avalara admin -> Organization -> choose organization -> Nexus Jurisdictions, please, review 
screenshot below : 

 

 
Then you will have two representations of customs duty on your magento website storefront : 

➢ Import duties included into grand total in the cart : 
 

 
➢ Import duties as a message in the cart : 

 



 

Third parties integrations 
AvaTax stores all collected import duties in special fields 

➢ avatax_landed_cost_import_duties_amount 
➢ base_avatax_landed_cost_import_duties_amount 

You also could find all collected tax in json format in additional special field 
avatax_collected_taxes.  
These all fields are present for entities listed below : 

➢ quote_address 
➢ quote_item 

 
➢ order 
➢ order_item 

 
➢ invoice 
➢ invoice_item 

 
➢ creditmemo 
➢ creditmemo_item 

Shipping Insurance 
AvaTax extension has special event that allows seller to include into request shipping insurance 
amount during tax calculation. Extension has such implementation because sellers could use 
some third party for insurance amount calculations. Please, review 
avatax_landed_cost_request_tax_insurance_needs event. 

 



Document Management (Exemption Certificates) 

Seller Side 

System Configuration 
Seller could find AvaTax Document Management configuration if you browse to  
admin -> System / Configuration -> SALES / Tax -> AvaTax Document Management section under 
AvaTax Custom Duty Calculator section. 
Configuration : 

➢ Action. You able to Enable / Disable document management for magento customers. 

 
To connect Avatax extension you should enter valid credentials: 

➢ REST V2 credentials : 
- URL: production or development endpoint urls 

 



- Account Number : this string is a UUID issued by Avalara to identify the Avalara 
account that owns the company identified by the Company Code. Mostly it’s the 
same value as you used in AvaTax / Connection Settings section. 

- Key : the Authorization is used to identify the actor (person or system) making 
the request. Mostly it’s the same value as you used in AvaTax Connection 
Settings section. 

➢ Cart capture Api 
- URL: production or development endpoint urls 
- Username & Password : seller credentials to access Cart Capture Api 
- Client ID: seller client ID in Avalara Cart Capture system. 

 
Customer / AvaTax Documents tab 

 
General Information 

➢ Customer Number : it’s crucial aspect of Document Management, this number is used 
during tax calculation and tax exemption. Seller could fill Customer Number to link 
already registered customer in Avalara with magento Customer Account or leave it 
blank. If Customer Number is blank during exemption certificate creation then extension 
generates Customer Number itself. Customer email is used for this purpose but if 
customer email contains symbols that have to be escaped then magento customer id is 
used. Seller has to know that Customer Number is magento customer attribute that 
means AvaTax / Data Mapping / Customer Code Format should be configured as 
customer attribute, well seller could use any customer attribute but we suggest to use 
avatax_customer_code. 

 



➢ [Send invitation email to customer] button : this button sends invitation letter to customer 
from Avalara.  

➢ [Update Customer Information in Avalara] button: allows seller to register new customer 
in Avalara or update existing one. 

Certificates grid 

 
Allows seller to Revoke, View and Download certificates. Seller also available to print certificate 
when seller view it. All certificates presented in pdf format. 

 
Seller allows to create certificate for particular customer from grid with [New Certificate] button. 
When [New Certificate] button is pressed Avalara New Certificate Creation Wizard appears. 

 



 
 

Customer Side 
Magento customer has ability to create, revoke, view and download certificates via My Account / 
AvaTax Documents tab in customer cabinet. Customer able to print certificate while customer 
views it. 

 
When [Create New Exempt Certificate] button is pressed Avalara New Certificate Creation Wizard 
appears. Customer also able to create new certificate in a cart and during Order Review step via 
special button [Is This Purchase Tax-Exempt?] 

 



 

 

 



 

Error Handling 

Error Handling allows to set up system behavior and control error messages in case                           

when tax cannot be calculated. This setting makes sense only when Validation: disabled. If                           

Validation is enabled, then Action on Error is ignored. 

To set up Error Handling go to Admin Panel > System > Configuration > Sales > Tax >                                   

Avatax: Error Handling. 

 

Admin can configure the following settings: 

➢ Action on Error: it controls system behavior when tax cannot be calculated. Pay attention                           

that Action on Error has lower priority than Validation and Normalization settings so if                           

you prefer to use Action on Error please disable setting under “Shipping Address                         

Options” block in AvaTax Configuration Page.  

Admin is able to select one of two available values for Action on Error:  

○ Disable checkout and show error message. When user enters non taxable                     

Shipping Address, error message is displayed and user is not able to go to the                             

next Checkout Step. In case when Validation is set to “Enable+Allow order” and                         

non-taxable address is provided, user is able to complete the checkout without                       

 



charging tax. If user calculates tax in Estimation block of Shopping Cart then                         

error message is displayed. 

○ Allow checkout without charging tax (no error message). This setting blocks                     

Validate Request: it is not sent during placing Order. After entering non taxable                         

Shipping Address, user is able to go to the next Checkout Step and place Order. If                               

user calculates tax in Estimation block of Shopping Cart then error message is                         

not displayed and user is able to go to Checkout. Pay attention that if Validation                             

is set to “Enable+Prevent Order” then user will not be able to place Order with non                               

taxable address - error message will be shown. 

➢ Frontend Error Message: this message is displayed on StoreFront (Shopping Cart and                       

Checkout) if tax cannot be calculated 

➢ Backend Error Message: this message is displayed when admin places an Order and tax                           

cannot be calculated 

➢ Notification Toolbar: this will be displayed on all admin pages if there are any errors with                                

items in the Queue (like admin messages).  

 

 

You can read more about Queue on Order Sync Queue Page. 

 

 



Filter Requests 

 

Filter Requests allow to calculate taxes and validate addresses only for some Countries /                           

States / Provinces. Because of Filter Requests settings it is possible to decrease number of                             

Requests to Avalara by filtering Shipping Addresses. If Shipping Address is filtered then Filter                           

log is displayed instead of Validate and GetTax Logs. 

Go to Admin Panel > System > Configuration > Sales > Tax > Avatax: Connection Settings                               

to configure Filter Requests. 

Admin is able to configure the following settings: 

➢ Taxable Country: select countries to be taxable 

➢ Filter Requests by Region: this allows admin to select one of the following values: 

○ None: Validation / Normalization and Tax calculation is performed for all                     

countries specified under Taxable Country field 

○ Filter tax calculations: Tax calculation and reporting only occur for the regions                       

selected — address validation and normalization still occur for all transactions 

○ Filter tax calculations & address options: All types of Avatax services (Validation,                       

Normalization, Tax Calculation) only occur for the regions selected 

➢ Taxable Regions: this field appears only if Filter Requests by Region equals “Filter tax                           

calculations” or “Filter tax calculations & address options”. Taxable Regions allow to                       

control Avatax Request only for selected regions.  

Example #1:  

Taxable Country: United States 

Filter Requests by Region: None 

In this case tax, validation and normalization will be performed for any US states. If user                               

selects Shipping Address with other country tax, validation and normalization will not be                         

performed. 

Example #2:  

Taxable Country: United States 

Filter Requests by Region: Filter tax calculations 

Taxable Regions: New York 

 



In this case tax is calculated only for New York state of US. Validation and Normalization                               

are performed for all states of US. So if user on StoreFront selects New Jersey state for                                 

Shipping, Validation and Normalization are performed, but tax is not calculated. Filter log will be                             

displayed instead of Validation Log (Validation Request is not sent). 

Example #3:  

Taxable Country: United States 

Filter Requests by Region: Filter tax calculations & address options 

Taxable Regions: New York 

In this case tax, validation and normalization will be performed only for New York state                             

of US. So Filter log is displayed instead of Validation, GetTax logs (Requests to Avalara are not                                 

sent). 

Filter log is not an actual request to Avalara; it is just notice that address was filtered.                                 

See Logging to find more information about logs. 

   

 



Request Settings 

Request Settings allow to decrease number Avatax Requests by blocking Avatax                     

Process if StoreFront User tries to enter invalid data that is marked as ‘Prohibited’ in Admin                               

Panel.  

 

 

 

To set up Request Settings go to Admin Panel > System > Configuration > Sales > Tax >                                   

Avatax: Request Settings. 

You can configure the following settings to activate Request Settings: 

➢ Required Fields: if some field is selected, it means that value entered to equivalent field                             

of Shipping Address on Checkout should not be empty or should not be equal value from                               

Field Rule. Admin is able to select one or few Required Fields. 

➢ Field Rule: value for Required Fields. Admin is able to enter one or few values via commas.                                 

So user should be able to go to the next Checkout Steps only if Required Field in Shipping                                   

Address is not empty and is not equal value from Field Rule.  

Please note that entered Field Rule values work for all selected Required Fields so it is                               

impossible to specify different Rules for different Required Fields. 

Request Settings are actual and make sense in case when Validation will be performed for                             

the Shipping Address. If shipping country or region is not selected as taxable and Validation is not                                 

performed, then Request Settings Verification is ignored. See Filter Requests to find more                         

information about settings of taxable and non taxable countries. 

 



Example:  

Required Fields: Company 

Field rule: ' ,-,_'  

In this case, when user goes to checkout and enters / selects Shipping Address, system                             

verifies “Does the Company field is empty?”, “Does the Company field equal ‘ ‘ (space), ‘-’ (dash) or ‘_’                                     

(upper dash)?”. If answer for one of these questions is “Yes” then error message is displayed and                                 

user is not able to go to the next Checkout Steps till he / she enters valid value for Company Code. If                                           

error message is displayed then Validation and GetTax requests are not sent.  

Logging 

Data logging is used to collect information about any Avatax actions or requests to                           

Avalara. Logs are saved to Avatax Log table (Admin Panel > Sales > Tax > Avatax Logs).  

To configure Logs go to Admin Panel > System > Configuration > Sales > Tax > Avatax :                                   

Log & Queue Settings. 

 

 

 



 

Admin is able to configure the following Logs Settings: 

➢ Log Mode: admin is able to choose what logs should be saved to table. There are three                                 

available values: 

○ Log only errors: it means that only logs with Level “Error” will be saved.                           

Successful entries will be ignored 

○ Log all actions (recommended): all Error and Successful Logs will be saved to                         

Avatax Log table 

➢ Enable Advanced Logs: if turned on then log layer collects related data for orders,                           

invoices and credit memos. 

➢ Log Entry Lifetime: Records in the Log are automatically deleted after time period                         

specified 

➢ Log Type: only selected log types will be saved to Logs table. Not selected logs Types                               

will be ignored and will not be saved to table. 

There are 5 Logs Types: 

➢ Ping: it is not Request to Avalara; it is a log that says about Avatax configuration                               

changes. Every time when admin saves Avatax extension changes, log Ping is saved to                           

Logs table. if Avatax is saved with invalid configurations then Level of Ping Log is “Error”;                               

if Avatax is saved with valid configurations, Ping log is present with level “Success” 

➢ GetTax: it is a request to Avalara. Every time when tax for Order needs to be calculated                                 

GetTax request is sent and appropriate log is saved to Log table. If tax can be calculated                                 

by Avalara and its value is sent in Response, then GetTax Log has Level “Success”. If tax                                 

cannot be calculated and error is sent in Response, GetTax is saved with Level “Error”.                             

Another case for GetTax log is related to Invoice and Credit Memo. GetTax is sent when                               

tax for Invoice or Credit Memo needs to be calculated. 

➢ Validate: it is a request to Avalara to validate and normalize shipping address. Validate                           

request is sent with Shipping Address; normalized Shipping Address is returned in                       

Response. Validate log has “Success” level if Avalara can validate / normalize shipping                         

address; if error message instead of normalized Shipping address is sent in Response                         

then Validate log is saved with level “Error” 

➢ Filter: it is not request to Avalara. It is just log that is displayed when tax or validation /                                     

normalization cannot be performed because of Request Settings. If Shipping Address is                       

filtered and tax or validation / normalization cannot be performed, log Filter displays.                         

 



Filter log can be displayed with only “Success” Level. See Filter Requests to get more                             

info. 

➢ Queue: it is not an actual request to Avalara. When Queue log is present in table it means                                   

that any operation with Invoice / Credit Memo were performed: adding Invoice / Credit                           

Memo to Avatax Order Sync Queue table; sending Invoice / Credit Memo from Avatax                           

Order Sync Queue table to Avalara admin; deleting Queue entries from table. 

 

Avatax Action Log table consists of the following columns: 

➢ Log Id: it is the log sequence number 

➢ Store Id: identification number of store which Avatax operation or request was                       

performed from. 

➢ Level: it indicates successful or failed requests. If Avatax operation or request is                         

successful then log displays with Level “Success”; if error display in Response and                         

operation is unsuccessful then Log Level is “Error”. 

➢ Type: Avatax operation or request name is displayed (log types were described                       

previously) 

➢ Quote Id: all sales documents come from quote and are linked to quote. 
➢ Quote Address Id: all calculations based on quote shipping or billing addresses. Column 

contains quote address id that was used during tax calculations for particular Avalara 
request. 

➢ Order #: magento sales order incremental id. Column’s data can't be filtered or sorted. 
➢ Invoice #: magento invoice incremental id. There can be multiple invoices per quote 

address id if partial invoicing took place. Column’s data can't be filtered or sorted. 
➢ Credit Memo #: magento credit memo incremental id per each magento invoice. 

Column’s data can't be filtered or sorted. 
➢ Created At: date when Log / Request is created / sent 

To see table with logs go to Admin Panel > Sales > Tax > AvaTax Log. 

 

Any log contains Request, Response and Additional information block. 

 



 

Admin is able to Export Logs table with all existing records in it. To do this go to Admin                                     

Panel > System > Configuration > Sales > Tax > Avatax > Log & Queue Settings > Export Logs) 

Order Sync Queue  

All Orders can be transferred to Avalara admin with the purpose to formulate reports and                             

detailed statistics. To sync with Avalara admin panel, Invoice and/or Credit Memo should be                           

created for Order. 

 



Invoices and Credit Memos that are prepared for sending to Avalara admin are collected                           

into Order Sync Queue table.  

To configure Avatax Order Sync Queue go to Admin Panel > System > Configuration >                             

Sales > Tax > Avatax > Action: enable: calculate tax, submit data 

To see Queue table go to Admin Panel > Sales > Tax > AvaTax Order Sync Queue. 

 

When Action is "enable: calculate tax, submit data" or "enable: calculate tax, submit data                           

and commit" Invoices/Credit Memos are automatically sent to AvaTax Order Sync Queue table after                           

its creation with Uncommited or Committed status respectively. When Invoices / Credit Memos are                           

present in Queue table they can be sent to Avalara admin by clicking "Process Queue Now" button on                                   

"Avatax Order Sync Queue" tab. In this case all data from Avatax Order Sync Queue is delivered to                                   

Avalara Admin. 

There are 5 different statuses of Orders/Invoices/Credit memos: 

1. Pending: all Invoices / Credit Memos are sent to Order Sync Queue table with statuses                             

"Pending". Pending status means that Invoice / Credit Memo is new and it is not present                               

in Avalara Admin. 

2. Retry Pending: when admin tries to send Invoices / Credit Memos to Avalara Admin but                             

attempt is unsuccessful, Invoices / Credit Memos are returned with status "Retry                       

Pending".  Reasons of unsuccessful attempt:  

a. order is placed with non taxable address;  

b. AvaTax is saved with invalid Connection Settings;   

c. Invoices / Credit Memos IDs already exist in Avalara admin. 

Invoices / Credit Memos can be returned with statuses "Retry Pending" four times. When                           

Retry Pending Queue is sent fifth time and attempt is unsuccessful, then Queue returns                           

with status "Failed". 

 



3. Failed status means that Invoices / Credit Memos are sent to Avalara Admin fifth time                             

and no one attempt is successful. Queue item status can be changed from "Failed" to                             

"Pending" using "Set pending status" link. 

4. Unbalanced. Since tax rates and configurations can change, the tax amount of orders                         

can also change from the time the customer checks out and when orders are invoiced. If                               

this happens, items in the queue will change to Unbalanced status and the difference will                             

be recorded. Magento will continue to use the old amount (since that is what you                             

collected from the customer) and the AvaTax dashboard will show the correct amount to                           

be paid to the respective jurisdiction. 

Example: To make status of Invoices / Credit Memos Unbalanced you should: 

a. place order on StoreFront; 

b. open order as admin (admin panel > Sales > Orders); 

c. change Shipping Address to new one; 

d. create Invoice/Credit Memo for Order; 

e. send Queue to Avalara Admin. 

5. Complete. When Invoice / Credit Memo is successfully sent to AvaTax admin console, it                           

returns with status "Complete". 

When Invoice / Credit Memo is created, it is automatically sent to Queue, Log "Queue"                             

created in Log table (admin panel > Sales > Tax > Avatax Logs). Queue is not a request; it is just                                         

log that indicates fact about Queue process. 

When Invoice / Credit Memo sends to Avalara admin, Logs "Queue" and "GetTax" are                           

created in Log table.  

To delete Queue with statuses "Complete", "Failed", "Unbalanced" manually, you can click a                         

button "Clear Queue Now". When admin deletes Queue, log “Queue” creates. 

Admin is able to set up the following configuration to delete Queue automatically (Admin                           

Panel > System > Configuration > Sales > Tax > Avatax > Log & Queue Settings): 

➢ Successful Queue Lifetime: Successful queue entries (Invoices / Credit Memos with                     

statuses "Complete") are automatically deleted after time specified. 

➢ Failed Queue Lifetime: Invoices / Credit Memos with statuses "Failed" and "Unbalanced"                       

are automatically deleted after time specified. 

Admin is able to Export Queue with all existing records in it. To do this go to Admin Panel                                     

> System > Configuration > Sales > Tax > Avatax > Log & Queue Settings > Export Queue). 

 

 



Export AvaTax Configuration 

You could export configuration of AvaTax extension. To do this go to Admin Panel > 
System > Configuration > Sales > Tax > Avatax > Log & Queue Settings and press [Export Config] 
button. Please, review screenshot below. 

 

Order Logs Export 

Magento Sales Order view screen contains AvaTax tab with Export Logs button for this                           

order. Button is enabled if advanced logging is turned on in extension configuration. When you                             

 



press export button, you will download detailed transaction logs as well as database data for                             

particular order and all related sales documents. 

 

List of hidden and overridden settings   

When Avatax is installed and enabled, some default Magento settings are hidden and their                           

behaviour is overridden.  

System > Configuration > Sales > Tax > Tax Classes section 

● Tax Class for Shipping - Set to Default Avatax shipping code FR020100 

System > Configuration > Sales > Tax > Calculation Settings section 

● Tax Calculation Method Based On - Set to Total 

● Tax Calculation Based On - Set to Shipping Address 

● Shipping Prices - Set to Catalog Prices value 

● Apply Customer Tax - Hidden when Catalog Prices = Exclude Tax and set to After                             

Discount 

● Apply Discount on Prices - Set to Catalog Prices value 

● Apply Tax On - set to Custom price if available 

● Enable Cross Border Trade - set to Yes when Catalog Prices = Include Tax and to No                                 

when Catalog Prices = Exclude Tax 

System > Configuration > Sales > Tax > Price Display Settings section 

● Display Product Prices - Set to Catalog Prices value 

 



● Display Shipping Prices - Set to Catalog Prices value 

System > Configuration > Sales > Tax > Orders, Invoices, Credit Memos Display Settings 

● Display Full Tax Summary - Set to No 

Sales > Tax  

● Manage Tax Rules 

● Manage Tax Zones & Rates 

● Import / Export Tax Rates 

 
 

 


